Выполнение произвольного кода в Apache Struts

Дата публикации:09.03.2017
Всего просмотров:9267
Опасность:
Критическая
Наличие исправления: Да
Количество уязвимостей:1
CVSSv2 рейтинг: 10 (AV:N/AC:L/Au:N/C:C/I:C/A:C/E:H/RL:O/RC:C)
CVE ID: CVE-2017-5638
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Активная эксплуатация уязвимости
Уязвимые продукты: Apache Struts 2.x
Уязвимые версии: Apache Struts версии 2.3.5 по 2.3.31 и 2.5 по 2.5.10
Описание:

Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в HTTP заголовке Content-Type. Удаленный пользователь может с помощью специально сформированного HTTP POST запроса осуществить инъекцию Java кода и выполнить его на уязвимой системе.

Примечание: уязвимость активно эксплуатируется в настоящее время.

URL производителя: https://www.apache.org
Решение: Установите последнюю версию 2.3.32 или 2.5.10.1 с сайта производителя.
Ссылки: https://cwiki.apache.org/confluence/display/WW/S2-045