Отказ в обслуживании в Django

Дата публикации:
19.08.2015
Дата изменения:
19.08.2015
Всего просмотров:
796
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:P/E:U/RL:OF/RC:C) = Base:6.4/Temporal:4.7
(AV:N/AC:L/Au:N/C:N/I:P/A:P/E:U/RL:OF/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
CVE-2015-5963
CVE-2015-5964
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Django 1.4.x
Django 1.7.x
Django 1.8.x
Уязвимые версии:
Django 1.4
Django 1.7
Django 1.8

Описание:

Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

1. Уязвимость существует из-за ошибки в компоненте "django.contrib.sessions.middleware.SessionMiddleware", позволяющей стороннему пользователю получить доступ к django.contrib.auth.views.logout и создать чрезмерно много новых записей сессии. Удаленный пользователь может сделать невозможным создание новых записей и вызвать отказ в обслуживании.

2. Уязвимость существует из-за ошибки в методах "contrib.sessions.backends.base.SessionBase.flush()" и "cache_db.SessionStore.flush()", позволяющей стороннему пользователю получить доступ к django.contrib.auth.views.logout и создать чрезмерно много новых записей сессии. Удаленный пользователь может сделать невозможным создание новых записей и вызвать отказ в обслуживании.


URL производителя: djangoproject.com

Решение: Установите последнюю версию с сайта производителя.

Ссылки: https://www.djangoproject.com/weblog/2015/aug/18/security-releases/