Межсайтовый скриптинг в WordPress Paid Memberships Pro

Дата публикации:28.07.2015
Всего просмотров:1748
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVSSv2 рейтинг: 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C)
CVE ID: CVE-2015-5532
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: WordPress Paid Memberships Pro Plugin 1.x
Уязвимые версии: Paid Memberships Pro WordPress версии 1.8.4.2, и, возможно, более ранние версии
Описание:

Уязвимость позволяет удаленному пользователю осуществить XSS-атаку.

Уязвимость существует из-за ошибки при обработке входных данных в параметре "s" в сценарии /wp-admin/admin.php" (когда параметр "page" равен "pmpro-membershiplevels"). Удаленный пользователь может с помощью специально сформированной ссылки выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: paidmembershipspro.com
Решение: Установите последнюю версию с сайта производителя.
Ссылки: http://www.paidmembershipspro.com/2015/07/pmpro-updates-1-8-4-3-and-1-8-4-4/