Множественные уязвимости в шлюзовых устройствах ANTlabs

Дата публикации:10.07.2015
Всего просмотров:2064
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:2
CVSSv2 рейтинг: 6.4 (AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C)
4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C)
CVE ID: CVE-2015-2849
CVE-2015-2850
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: InnGate 3.х
SSG 4
Уязвимые версии: IG 3100
IG 3101
InnGate 3.00 E-Series
InnGate 3.01 E-Series
InnGate 3.02 E-Series
InnGate 3.10 E-Series
InnGate 3.01 G-Series
InnGate 3.10 G-Series
SSG 4
SG 4
Описание:

Уязвимость позволяет удаленному пользователю осуществить SQL-инъекцию.

1. Уязвимость существует из-за ошибки при обработке входных данных в URL параметре ppli на странице авторизации. Удаленный пользователь может выполнить произвольные команды в базе данных.

2. Уязвимость существует из-за ошибки при обработке входных данных в URL параметре msg на странице авторизации. Удаленный пользователь может осуществить XSS-атаку.

URL производителя: antlabs.com
Решение: Установите последнюю версию с сайта производителя.
Ссылки: http://www.antlabs.com/advisory-sql-injection-reflected-cross-site-scripting-vulnerabilities/