Выполнение произвольного кода в Adobe Flash Player

Дата публикации:
07.07.2015
Дата изменения:
10.07.2015
Всего просмотров:
8078
Опасность:
Критическая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:H/RL:O/RC:C) = Base:10/Temporal:8.7
CVE ID:
CVE-2015-5119
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Активная эксплуатация уязвимости
Уязвимые продукты:
Adobe Flash Player 18.x
Уязвимые версии:
Adobe Flash Player 18.0.0.194 и более ранние версии

Описание:

Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки использования после освобождения в классе ByteArray. Удаленный пользователь может с помощью специально сформированного .sfw файла вызвать переполнение буфера и выполнить произвольный код на целевой системе.

Примечаение: эксплоит к уязвимости был обнаружен в архивах компании Hacking Team, опубликованных в открытом доступе.


URL производителя: http://www.adobe.com

Решение: Установите последнюю версию с сайта производителя.
10.07.15 Незначительные изменения в описании. Добавлен идентификатор CVE.