Межсайтовый скриптинг в pfSense

Дата публикации:25.03.2015
Всего просмотров:1774
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:2
CVSSv2 рейтинг: 2.6 (AV:N/AC:H/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C)
5.4 (AV:N/AC:H/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C)
CVE ID: CVE-2015-2294
CVE-2015-2295
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: pfSense 2.x
Уязвимые версии: pfSense 2.2, возможно более ранние версии
Описание:

Удаленный пользователь может осуществить XSS-атаку.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "zone" в сценарии /status_captiveportal.php, в параметрах "if" и "dragtable" в сценарии /firewall_rules.php, а также в параметре "queue" в сценарии /firewall_shaper.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может с помощью специально сформированной ссылки осуществить CSRF нападение и удалить произвольные файлы на целевой системе с корневыми привилегиями.

URL производителя: https://www.pfsense.org/
Решение: Установите последнюю версию с сайта производителя.
Ссылки: https://blog.pfsense.org/?p=1661