SQL-инъекция в WordPress Survey and Poll Plugin

Дата публикации:
03.03.2015
Дата изменения:
03.03.2015
Всего просмотров:
999
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:P/RL:OF/RC:C) = Base:7.5/Temporal:5.9
CVE ID:
CVE-2015-2090
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Survey and Poll Plugin 1.x
Уязвимые версии:
WordPress Survey and Poll Plugin 1.1.7 и более ранние версии

Описание:

Уязвимость позволяет удаленному пользователю осуществить SQL-инъекцию.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "survey_id" в функции "ajax_survey" в сценарии settings.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.


URL производителя: https://wordpress.org/plugins/wp-survey-and-poll/

Решение: Установите исправление с сайта производителя.

Ссылки: https://wordpress.org/plugins/wp-survey-and-poll/changelog/
http://www.exploit-db.com/exploits/36054/
http://packetstormsecurity.com/files/130381/WordPress-Survey-And-Poll-1.1.7-Blind-SQL-Injection.html
http://osvdb.org/show/osvdb/118218