Раскрытие важных данных в Jetty

Дата публикации:
26.02.2015
Дата изменения:
26.02.2015
Всего просмотров:
1032
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:P/RL:OF/RC:C) = Base:5/Temporal:3.9
CVE ID:
CVE-2015-2080
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Jetty 9.x
Уязвимые версии:
Jetty с 9.2.3 по 9.2.8

Описание:

Уязвимость позволяет удаленному пользователю раскрыть важные данные.

Уязвимость существует из-за неизвестной ошибки. Удаленный пользователь может раскрыть важные данные, включая аутентификационную информацию.


URL производителя: http://eclipse.org/jetty/

Решение: Установите исправление с сайта производителя.

Ссылки: http://blog.gdssecurity.com/labs/2015/2/25/jetleak-vulnerability-remote-leakage-of-shared-buffers-in-je.html
https://github.com/eclipse/jetty.project/blob/master/advisories/2015-02-24-httpparser-error-buffer-bleed.md