Множественные уязвимости в Oracle MySQL Server

Дата публикации:
17.02.2015
Дата изменения:
17.02.2015
Всего просмотров:
2270
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
9
CVSSv2 рейтинг:
(AV:A/AC:L/Au:N/C:P/I:P/A:C/E:U/RL:OF/RC:C) = Base:7.3/Temporal:5.4
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C) = Base:6.1/Temporal:4.5
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C) = Base:6.1/Temporal:4.5
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C) = Base:6.1/Temporal:4.5
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C) = Base:6.1/Temporal:4.5
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C) = Base:6.1/Temporal:4.5
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C) = Base:6.1/Temporal:4.5
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C) = Base:6.1/Temporal:4.5
(AV:A/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:3.3/Temporal:2.4
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MySQL 5.x
Уязвимые версии:
MySQL Server 5.5.40 и более ранние версии
MySQL Server 5.6.21 и более ранние версии

Описание:

1) Уязвимость существует из-за ошибки в подкомпоненте "Server : Security : Encryption" . Удаленный пользователь может раскрыть, обновить, вставить или удалить определенные данные, а также вызвать аварийное завершение работы.

2) Уязвимость существует из-за ошибки в подкомпоненте "Server : Replication" . Удаленный пользователь может вызвать аварийное завершение работы.

3) Уязвимость существует из-за ошибки в подкомпоненте "Server : Replication" . Удаленный пользователь может вызвать аварийное завершение работы.

4) Уязвимость существует из-за ошибки в подкомпоненте "Server : DDL" . Удаленный пользователь может вызвать аварийное завершение работы.

Примечание: Уязвимость существует в версиях 5.5.38 и более ранних версиях, а также в версии 5.6.19 и более ранних версиях.

5) Уязвимость существует из-за ошибки в подкомпоненте "Server : InnoDB : DDL : Foreign Key" . Удаленный пользователь может вызвать аварийное завершение работы.

Примечание: Уязвимость существует в версиях 5.5.40 и более ранних версиях.

6) Уязвимость существует из-за ошибки в подкомпоненте "Server : Optimizer" . Удаленный пользователь может вызвать аварийное завершение работы.

7) Уязвимость существует из-за ошибки в подкомпоненте "Server : InnoDB : DML" . Удаленный пользователь может вызвать аварийное завершение работы.

8) Уязвимость существует из-за ошибки в подкомпоненте "Server : Pluggable Auth" . Удаленный пользователь может вызвать аварийное завершение работы.

Примечание: Уязвимости с #6 and #8 существуют в версии 5.6.21 и более ранних версиях.

9) Уязвимость существует из-за ошибки в подкомпоненте "Server : Security : Privileges : Foreign Key" . Удаленный пользователь может раскрыть определенные данные.

Примечание: Уязвимости с #1 по #3, #7 и #9 существуют в версии 5.5.40 и более ранних версиях, а также в версии 5.6.21 и более ранних версиях.


URL производителя: http://dev.mysql.com/downloads/

Решение: Установите исправление с сайта производителя.

Ссылки: http://www.oracle.com/technetwork/topics/security/cpujan2015-1972971.html#AppendixMSQL<
http://www.oracle.com/technetwork/topics/security/cpujan2015verbose-1972976.html#MSQL<