Множественные уязвимости в FreeBSD

Дата публикации:
30.01.2015
Дата изменения:
30.01.2015
Всего просмотров:
1921
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:L/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:OF/RC:C) = Base:6.9/Temporal:5.1
(AV:L/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:1.9/Temporal:1.4
CVE ID:
CVE-2014-8612
Вектор эксплуатации:
Локальная
Воздействие:
Раскрытие важных данных
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FreeBSD 9.x
Уязвимые версии:
OpenBSD 9.3

Описание:

Уязвимости позволяют удаленному пользователю скомпрометировать систему.

1) Уязвимость существует из-за ошибки выхода за пределы памяти в функции "sctp_setopt()" (sys/netinet/sctp_userreq.c). Удаленный пользователь может повысить привилегии и выполнить произвольный код.

Примечание: Успешная эксплуатация уязвимости требует, чтобы опция сокета SCTP была установлена на значение "SCTP_SS_VALUE".

2) Уязвимость существует из-за ошибки выхода за пределы памяти в функции "sctp_setopt()" (sys/netinet/sctp_userreq.c). Удаленный пользователь может раскрыть важные данные.

Примечание: Успешная эксплуатация уязвимости требует, чтобы опция сокета SCTP была установлена на значение "SCTP_SS_VALUE".


URL производителя: http://www.freebsd.org/releases/9.0R/announce.html

Решение: Установите исправление с сайта производителя.

Ссылки: https://www.freebsd.org/security/advisories/FreeBSD-SA-15:02.kmem.asc
http://www.coresecurity.com/advisories/freebsd-kernel-multiple-vulnerabilities