Множественные уязвимости в FFmpeg

Дата публикации:
20.01.2015
Дата изменения:
20.01.2015
Всего просмотров:
706
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-9602
CVE-2014-9603
CVE-2014-9604
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Раскрытие важных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FFmpeg 2.x
Уязвимые версии:
FFmpeg до 2.2.12
FFmpeg до 2.4.5
FFmpeg до 2.5.2

Описание:

Уязвимости позволяют удаленному пользователю обойти ограничения безопасности, осуществить DoS-атаку и раскрыть важные данные.

1) Уязвимость существует из-за ошибки при обработке файлов X-Face. Удаленный пользователь может обойти ограничения безопасности.

2) Уязвимость существует из-за ошибки в функции "vmd_decode()" (libavcodec/vmdvideo.c). Удаленный пользователь может раскрыть важные данные.

3) Уязвимость существует из-за ошибки в функциях "restore_median()" и "restore_median_il()" (libavcodec/utvideocodec.c). Удаленный пользователь может осуществить DoS-атаку.


URL производителя: http://ffmpeg.org/

Решение: Установите исправление с сайта производителя.

Ссылки: http://ffmpeg.org/security.html