Множественные уязвимости в FFmpeg

Дата публикации:
20.01.2015
Дата изменения:
20.01.2015
Всего просмотров:
577
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-9602
CVE-2014-9603
CVE-2014-9604
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Раскрытие важных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FFmpeg 2.x
Уязвимые версии:
FFmpeg версии до 2.2.12
FFmpeg версии до 2.4.5
FFmpeg версии до 2.5.2

Описание:

Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

1. Уязвимость существует из-за ошибки при обработке файлов X-Face. Удаленный пользователь может обойти ограничения безопасности.

Примечание: Уязвимость затрагивает версии до 2.5.2.

2. Уязвимость существует из-за ошибки в функции "vmd_decode()" в файле libavcodec/vmdvideo.c. Удаленный пользователь может обойти ограничения безопасности.

3. Уязвимость существует из-за ошибки в функциях "restore_median()" и "restore_median_il()" в файле libavcodec/utvideodec.c. Удаленный пользователь может обойти ограничения безопасности.


URL производителя: http://ffmpeg.org/

Решение: Установите последнюю версию 2.2.12, 2.4.5 или 2.5.2 с сайта производителя.

Ссылки: http://ffmpeg.org/security.html