Межсайтовый скриптинг в WordPress MP3-jPlayer

Дата публикации:
16.01.2015
Дата изменения:
16.01.2015
Всего просмотров:
845
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress MP3-jPlayer Plugin 1.x
Уязвимые версии:
WordPress MP3-jPlayer 1.8.11, возможно более ранние версии

Описание:

Уязвимость позволяет удаленному пользователю осуществить XSS-атаку.

Уязвимость существует из-за ошибки при обработке входных данных в параметре "mp3" в сценариях mp3-jplayer\download.php и mp3-jplayer\remote\downloader.php. Удаленный пользователь может с помощью специально сформированной ссылки выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.


URL производителя: https://wordpress.org/plugins/mp3-jplayer/

Решение: Установите последнюю версию 1.8.12 с сайта производителя.

Ссылки: http://security.szurek.pl/mp3jplayer-1811-reflected-xss.html