Спуфинг атака в Apache XML Security

Дата публикации:
29.12.2014
Дата изменения:
29.12.2014
Всего просмотров:
901
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2013-2172
Вектор эксплуатации:
Удаленная
Воздействие:
Спуфинг атака
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache XML Security (Java) 1.x
Уязвимые версии:
Apache XML Security версии до 1.5.5
Apache XML Security версии до 1.4.8

Описание:

Уязвимость позволяет удаленному пользователю осуществить спуфинг нападение.

Уязвимость существует из-за того, что библиотека неправильно ограничивает доступ к алгоритмам canonicalization. Удаленный пользователь может осуществить спуфинг нападение и раскрыть XML Signature.


URL производителя: http://santuario.apache.org/

Решение: Установите последнюю версию 1.5.5 или 1.4.8 с сайта производителя.

Ссылки: http://santuario.apache.org/secadv.data/CVE-2013-2172.txt.asc