Множественные уязвимости в Adobe Flash Player

Дата публикации:
25.12.2014
Дата изменения:
25.12.2014
Всего просмотров:
864
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
5
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:OF/RC:C) = Base:9.3/Temporal:6.9
(AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:OF/RC:C) = Base:9.3/Temporal:6.9
(AV:N/AC:M/Au:N/C:C/I:C/A:C/E:F/RL:OF/RC:C) = Base:9.3/Temporal:7.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
CVE-2014-0580
CVE-2014-0587
CVE-2014-8443
CVE-2014-9162
CVE-2014-9163
CVE-2014-9164
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Adobe Flash Player 11.x
Adobe Flash Player 13.x
Уязвимые версии:
Adobe Flash Player Extended Support Release 13.0.0.258 и более ранние версии
Adobe Flash Player для Linux 11.2.202.424 и более ранние версии

Описание:

Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за неизвестных ошибок. Удаленный пользователь может вызвать повреждение памяти и скомпрометировать целевую систему.

2. Уязвимость существует из-за ошибки использования после освобождения. Удаленный пользователь может скомпрометировать целевую систему.

3. Уязвимость существует из-за ошибки, связанной с функцией "parseFloat()". Удаленный пользователь может вызвать переполнение буфера и скомпрометировать целевую систему.

Примечание: На момент выпуска исправления уязвимость активно эксплуатировалась злоумышленниками.

Уязвимость существует из-за ошибки обработки границ данных при обработке Regular Expression Objects. Удаленный пользователь может получить доступ к определенной информации.

Уязвимость существует из-за неизвестной ошибки. Удаленный пользователь может обойти ограничения безопасности.


URL производителя: http://www.adobe.com/products/flashplayer.html

Решение: Установите последнюю версию с сайта производителя.

Ссылки: http://helpx.adobe.com/security/products/flash-player/apsb14-27.html
http://www.zerodayinitiative.com/advisories/ZDI-14-416/
http://www.zerodayinitiative.com/advisories/ZDI-14-417/