SQL-инъекция в Zabbix

Дата публикации:
18.12.2014
Дата изменения:
18.12.2014
Всего просмотров:
1096
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:A/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:4.8/Temporal:3.5
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ZABBIX 1.x
Zabbix 2.x
Уязвимые версии:
Zabbix версии до 1.8.22
Zabbix версии до 2.0.14
Zabbix версии до 2.2.8

Описание:

Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "periods" и "itemid" в сценарии chart_bar.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.


URL производителя: http://www.zabbix.com/

Решение: Установите последнюю версию 1.8.22, 2.0.14 или 2.2.8 с сайта производителя.

Ссылки: http://www.zabbix.com/rn1.8.22.php
http://www.zabbix.com/rn2.0.14.php
http://www.zabbix.com/rn2.2.8.php
https://support.zabbix.com/browse/ZBX-8582