Отказ в обслуживании в OpenVPN и OpenVPN Access Server

Дата публикации:17.12.2014
Всего просмотров:1063
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVSSv2 рейтинг: 5.7 (AV:A/AC:M/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C)
CVE ID: CVE-2014-8104
Вектор эксплуатации: Локальная сеть
Воздействие: Отказ в обслуживании
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: OpenVPN 2.x
OpenVPN Access Server 2.x
Уязвимые версии: OpenVPN 2.3.5 и более ранние версии
OpenVPN Access Server 2.0.10 и более ранние версии
Описание:

Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки при обработке пакетов контрольного канала. Злоумышленник может вызвать аварийное завершение работы программы, отправив специально сформированный пакет контрольного канала.

Примечание: для успешной эксплуатации уязвимости требуется, чтобы клиент был аутентифицирован через TLS (опция "tls-authenticated").

URL производителя: http://openvpn.net
Решение: Установите исправление с сайта производителя.
Ссылки: https://community.openvpn.net/openvpn/wiki/SecurityAnnouncement-97597e732b