Множественные уязвимости в MediaWiki

Дата публикации:
16.12.2014
Дата изменения:
16.12.2014
Всего просмотров:
716
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C) = Base:5.8/Temporal:4.3
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C) = Base:5.8/Temporal:4.3
CVE ID:
CVE-2014-9277
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MediaWiki 1.x
Уязвимые версии:
MediaWiki версии до 1.23.7
MediaWiki версии до 1.22.14
MediaWiki версии до 1.19.22

Описание:

Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

1. Уязвимость существует из-за недостаточной обработки входных данных в OutputHandler.php в функции "unserialize()". Удаленный пользователь может манипулировать определенными файлами или внедрить и выполнить произвольный PHP код.

Примечание: Для успешной эксплуатации уязвимости необходимо иметь привилегии "Editor".

2. Уязвимость существует из-за ошибки при обработке обновления для модели контента страницы. Удаленный пользователь может манипулировать защищенными CSS или JS файлами.

Примечание: Для успешной эксплуатации уязвимости необходимо, чтобы опция "wgContentHandlerUseDB" была включена.


URL производителя: http://wikipedia.sourceforge.net/

Решение: Установите последнюю версию 1.23.7, 1.22.14 или 1.19.22 с сайта производителя.