Множественные уязвимости в IBM DB2 и DB2 Connect

Дата публикации:12.12.2014
Всего просмотров:935
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:4
CVSSv2 рейтинг: 8.8 (AV:N/AC:M/Au:N/C:C/I:C/A:N/E:U/RL:OF/RC:C)
8.5 (AV:N/AC:L/Au:N/C:N/I:C/A:P/E:U/RL:OF/RC:C)
6.1 (AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C)
5.7 (AV:A/AC:M/Au:N/C:N/I:N/A:C/E:U/RL:OF/RC:C)
CVE ID: CVE-2014-3094
CVE-2014-3095
CVE-2014-6097
CVE-2014-6159
Вектор эксплуатации: Локальная сеть
Воздействие: Отказ в обслуживании
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: IBM DB2 9.x
IBM DB2 Connect 9.x
Уязвимые версии: IBM DB2 версии с 9.7.x до 9.7 Fix Pack 10
DB2 Connect версии с 9.7.x до 9.7 Fix Pack 10
Описание:

Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Подробное описание уязвимостей (#2, #3) доступно по адресу: http://www.securitylab.ru/vulnerability/458966.php

2. Уязвимость существует из-за неизвестной ошибки при обработке ALTER TABLE. Удаленный пользователь может аварийно завершить работу системы.

3. Уязвимость существует из-за неизвестной ошибки при обработке ALTER TABLE. Удаленный пользователь может аварийно завершить работу системы.

Примечание: Для успешной эксплуатации уязвимости #2 необходимо, чтобы DB2 была настройка immediate auto revalidation.

URL производителя: http://www-306.ibm.com/software/data/db2/db2connect/sysreqs.html
Решение: Установите последнюю версию с сайта производителя.
Ссылки: http://www.ibm.com/support/docview.wss?uid=swg24038641
http://www.ibm.com/support/docview.wss?uid=swg21450666
http://www.ibm.com/support/docview.wss?uid=swg21681631