Отказ в обслуживании в Firebird

Дата публикации:
10.12.2014
Дата изменения:
10.12.2014
Всего просмотров:
847
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:A/AC:L/Au:N/C:N/I:N/A:C/E:U/RL:O/RC:C) = Base:6.1/Temporal:4.5
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Firebird 2.x
Уязвимые версии:
Firebird версии до 2.1.7
Firebird версии до 2.5.3 Security Update 1

Описание:

Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки пори обработке специально сформированных пакетов. Удаленный пользователь может аварийно завершить работу базы данных.


URL производителя: http://www.firebirdsql.org/

Решение: Установите последнюю версию 2.1.7 или 2.5.3 Security Update 1 с сайта производителя.

Ссылки: http://www.firebirdsql.org/en/news/security-updates-for-v2-1-and-v2-5-series-66011/
http://www.firebirdsql.org/file/documentation/release_notes/html/rlsnotes217.html#rnfb210-v217
http://www.firebirdsql.org/file/documentation/release_notes/html/rlsnotes253_upd1.html#notes-253_su1
http://tracker.firebirdsql.org/browse/CORE-4630