Отказ в обслуживании в Perl Data::Dumper

Дата публикации:
02.12.2014
Дата изменения:
02.12.2014
Всего просмотров:
735
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-4330
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Data::Dumper 2.x (module for Perl)
Уязвимые версии:
Perl Data::Dumper версии до 2.154

Описание:

Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки неограниченной рекурсии при обработке входных данных. Удаленный пользователь может с помощью специально сформированных данных аварийно завершить работу приложения.


URL производителя: http://search.cpan.org/~smueller/Data-Dumper-2.154/Dumper.pm

Решение: Установите последнюю версию 2.154 с сайта производителя.

Ссылки: http://www.nntp.perl.org/group/perl.perl5.porters/2014/09/msg220118.html
https://www.lsexperts.de/advisories/lse-2014-06-10.txt