Обход ограничений безопасности в Smarty

Дата публикации:
02.12.2014
Дата изменения:
02.12.2014
Всего просмотров:
898
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:6.8/Temporal:5
CVE ID:
CVE-2014-8350
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Smarty 3.x
Уязвимые версии:
Smarty 3.1.20 и более ранние версии

Описание:

Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за ошибки в обработке тега "<script language=php>". Удаленный пользователь может ее проэксплуатировать и выполнить запрещенный PHP-код.


URL производителя: http://www.smarty.net/

Решение: Установите исправление 3.1.21 с сайта производителя.

Ссылки: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765920