Обход ограничений безопасности в GNU C Library

Дата публикации:
25.11.2014
Дата изменения:
25.11.2014
Всего просмотров:
635
Опасность:
Средняя
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:W/RC:C) = Base:7.5/Temporal:6.1
CVE ID:
CVE-2014-7817
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNU C Library (glibc) 2.x
Уязвимые версии:
GNU C Library 2.20

Описание: Уязвимость позволяет удаленному пользователю ограничения безопасности.

Уязвимость существует из-за того, что библиотека неправильно предотвращает замену команд. Удаленный пользователь может, к примеру, выполнить определенные команды оболочки.


URL производителя: http://www.gnu.org/software/libc/libc.html

Решение: Установите исправление из репозитория исходного кода.

Ссылки: https://sourceware.org/ml/libc-alpha/2014-11/msg00519.html
https://bugzilla.redhat.com/show_bug.cgi?id=1157689