Межсайтовый скриптинг в MODx

Дата публикации:
20.11.2014
Дата изменения:
20.11.2014
Всего просмотров:
1756
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MODx 1.x
Уязвимые версии:
MODx 1.0.15

Описание:
Уязвимость позволяет удаленному пользователю осуществить XSS-атаку.

1. Уязвимость существует из-за ошибки в параметрах "editor" и "type" в сценарии /manager/media/browser/mcpuk/browser.php. Удаленный пользователь может с помощью специально сформированной ссылки выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за ошибки при обработке входных данных в сценарии /assets/snippets/jot/jot.class.inc.php. Удаленный пользователь может с помощью специально сформированной ссылки выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может с помощью специально сформированной ссылки осуществить CSRF нападение.

URL производителя: http://modxcms.com/

Решение: Установите последнюю версию 1.0.15 с сайта производителя.



Ссылки: http://forums.modx.com/thread/94952/multiple-vulnerabilities-xss-remote-command-injection
https://github.com/modxcms/evolution/blob/develop/install/changelog.txt