Межсайтовый скриптинг в MODx

Дата публикации:
17.11.2014
Дата изменения:
22.11.2014
Всего просмотров:
1301
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:C/A:N/E:U/RL:OF/RC:C) = Base:7.8/Temporal:5.8
(AV:N/AC:L/Au:N/C:N/I:C/A:N/E:U/RL:OF/RC:C) = Base:7.8/Temporal:5.8
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MODx 2.x
Уязвимые версии:
MODx 2.2.14

Описание: Уязвимость позволяет удаленному пользователю осуществить XSS-атаку.</p>

1. Уязвимость существует из-за ошибки в GET параметре "context_key" в сценарии /manager/index.php. Удаленный пользователь может с помощью специально сформированной ссылки выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.</p>
2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может с помощью специально сформированной ссылки осуществить CSRF нападение. </p>
URL производителя: http://modxcms.com/

Решение: Установите последнюю версию 2.2.15 с сайта производителя.

Ссылки: http://forums.modx.com/thread/92152/critical-login-xss-csrf-revolution-2-2-1-4-and-prior
http://hacktivity.websecgeeks.com/modx-csrf-and-xss/