Множественные уязвимости в Pidgin

Дата публикации:
07.11.2014
Дата изменения:
07.11.2014
Всего просмотров:
1295
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C) = Base:6.4/Temporal:4.7
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C) = Base:6.4/Temporal:4.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-3694
CVE-2014-3697
CVE-2014-3698
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
Спуфинг атака
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Pidgin 2.x
Уязвимые версии:
Pidgin версии до 2.10.10

Описание:
Уязвимость позволяет удаленному пользователю осуществить спуфинг атаку, получить доступ к важным данным и манипулировать определенной информацией.

1. Уязвимость существует из-за того, что приложение неправильно проверяет \"Basic Constraints\" в SSL сертификате. Удаленный пользователь может осуществить спуфинг нападение.

2. Уязвимость существует из-за ошибки при распаковке темы смайлов. Удаленный пользователь может создать или перезаписать файлы в произвольной директории.

Примечание: Уязвимости #1 и #2 затрагивают исключительно версию программы для Windows.

3. Уязвимость существует из-за разборе XMPP сообщений. Удаленный пользователь может раскрыть содержимое памяти.

URL производителя: http://pidgin.im/

Решение: Установите последнюю версию 2.10.10 с сайта производителя.



Ссылки: http://pidgin.im/news/security/?id=86
http://pidgin.im/news/security/?id=89
http://pidgin.im/news/security/?id=90