Межсайтовый скриптинг в Forma Lms

Дата публикации:
05.11.2014
Дата изменения:
05.11.2014
Всего просмотров:
700
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-5257
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Forma Lms 1.х
Уязвимые версии:
Forma Lms 1.2.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю осуществить XSS-атаку.

1. Уязвимость существует из-за недостаточной обработки входных данных в HTTP GET параметре "id_custom" в сценарии /appCore/index.php. Удаленный пользователь может с помощью специально сформированной ссылки выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в HTTP GET параметре "id_game" в сценарии /appCore/index.php. Удаленный пользователь может с помощью специально сформированной ссылки выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://www.formalms.org/

Решение: Установите последнюю версию 1.2.1 p01 с сайта производителя.



Ссылки: http://sourceforge.net/projects/forma/files/version 1.x/