Множественные уязвимости в IBM OpenPages GRC Platform

Дата публикации:
23.10.2014
Дата изменения:
23.10.2014
Всего просмотров:
839
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
8
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C) = Base:5.8/Temporal:4.3
(AV:N/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2013-4286
CVE-2013-4590
CVE-2014-0033
CVE-2014-0075
CVE-2014-0095
CVE-2014-0096
CVE-2014-0099
CVE-2014-0119
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Раскрытие важных данных
Внедрение в сессию пользователя
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IBM OpenPages GRC Platform 6.x
Уязвимые версии:
IBM OpenPages GRC Platform 6.2.1.1

Описание:
Уязвимость позволяет удаленному пользователю перехватить сессию другого пользователя, получить доступ к важным данным и вызвать отказ в обслуживании.

1. Уязвимость существует из-за неизвестной ошибки при обработке определенных content-length заголовков. Удаленный пользователь может с помощью специально сформированной ссылки выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за ошибки при обработке session ID. Удаленный пользователь может внедриться в сессию другого пользователя.

Примечание: Для успешной эксплуатации уязвимости необходимо, чтобы disableURLRewriting был включен.

3. Уязвимость существует из-за ошибки при обработке определенных XML файлов. Удаленный пользователь может получить доступ к важным данным.

Примечание: Для успешной эксплуатации уязвимости необходимо, чтобы приложение было запущено из недоверенного источника.

4. Подробное описание уязвимостей (#1 - #4) доступно по адресу: http://www.securitylab.ru/vulnerability/453499.php

5. Уязвимость существует из-за ошибки во встроенном Apache Tomcat при обработке "Content-Length". Удаленный пользователь может вызвать отказ в обслуживании.

URL производителя: http://www.ibm.com/software/products/us/en/openpages-grc-platform/

Решение: Установите последнюю версию с сайта производителя.



Ссылки: http://www.ibm.com/software/products/us/en/openpages-grc-platform/