Обход ограничений безопасности в OpenSSL

Дата публикации:
16.10.2014
Дата изменения:
16.10.2014
Всего просмотров:
1325
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
CVE-2014-3568
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenSSL 1.0.0
OpenSSL 1.0.1
OpenSSL 0.9.8
Уязвимые версии:
OpenSSL версии до 1.0.1j
OpenSSL версии до 1.0.0o
OpenSSL версии до 0.9.8zc

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за того, что в OpenSSL присутствует встроенная опция "no-ssl3". Удаленный пользователь может заставить сервер принять рукопожатие SSL 3.0.

URL производителя: https://www.openssl.org/

Решение: Установите последнюю версию 0.9.8zc, 1.0.0o или 1.0.1jс сайта производителя.



Ссылки: https://www.openssl.org/news/secadv_20141015.txt