Отказ в обслуживании в GNU C Library

Дата публикации:
12.09.2014
Дата изменения:
12.09.2014
Всего просмотров:
911
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-6040
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Уязвимые версии: GNU C Library версии до 2.20

Описание:
Уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки обработки границ данных на страницах IBM1364, IBM932, IBM933, IBM935, IBM937, IBM939 и IBM943. Удаленный пользователь может вызвать переполнение динамической памяти.

URL производителя: http://www.gnu.org/software/libc/libc.html

Решение: Установите последнюю версию 2.20 с сайта производителя.

Ссылки: https://sourceware.org/bugzilla/show_bug.cgi?id=17325
https://sourceware.org/ml/libc-alpha/2014-09/msg00088.html