Межсайтовый скриптинг в Drupal Marketo MA

Дата публикации:
26.08.2014
Дата изменения:
26.08.2014
Всего просмотров:
695
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Marketo MA Module 7.x
Уязвимые версии: Dolibarr CMS 3.5.3, возможно более ранние версии

Описание:
Уязвимости позволяют удаленному пользователю осуществить XSS-нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в поле titles в модуле Marketo MA Webform. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Примечание: Для успешной эксплуатации уязвимости необходимо иметь права доступа \"create webform content\" и \"administer marketo webform settings\".

2. Уязвимость существует из-за недостаточной обработки входных данных в поле titles в модуле Marketo MA User. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Примечание: Для успешной эксплуатации уязвимости необходимо иметь права доступа \"administer users\" and \"administer marketo\".

URL производителя: https://www.drupal.org/project/marketo_ma

Решение: Установите последнюю версию 7.x-1.5 с сайта производителя.

Ссылки: https://www.drupal.org/node/2324813