Отказ в обслуживании в Pillow module for Python

Дата публикации:
21.08.2014
Дата изменения:
21.08.2014
Всего просмотров:
1079
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-3589
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Python Pillow Module 2.3.x
Python Pillow Module 2.5.x
Уязвимые версии:
Python Pillow версии до 2.3.2
Python Pillow версии до 2.5.2

Описание:
Уязвимость позволяет злоумышленнику произвести DoS атаку.

Уязвимость существует из-за ошибки при обработке ICNS файлов. Удаленный пользователь может произвести DoS атаку.

URL производителя: http://python-pillow.github.io/

Решение: Установите последнюю версию 2.3.2 или 2.5.2 с сайта производителя.

Ссылки: https://pypi.python.org/pypi/Pillow/2.3.2
https://pypi.python.org/pypi/Pillow/2.5.2