Множественные уязвимости в Drupal Biblio Autocomplete

Дата публикации:
11.08.2014
Дата изменения:
11.08.2014
Всего просмотров:
1000
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:5.8/Temporal:4.3
(AV:N/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Biblio Autocomplete Module 6.x
Drupal Biblio Autocomplete Module 7.x
Уязвимые версии:
Drupal Biblio Autocomplete версии до 7.x-1.5
Drupal Biblio Autocomplete версии до 6.x-1.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в субмодуле \"Biblio self autocomplete\". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за того, что приложение неправильно ограничивает доступ к AJAX autocompletion callback. Удаленный пользователь может получить доступ к важным данным.

URL производителя: https://www.drupal.org/node/2316717

Решение: Установите исправление с сайта производителя.

Ссылки: https://www.drupal.org/node/2316717