Множественные уязвимости в OpenSSL

Дата публикации:
07.08.2014
Дата изменения:
08.08.2014
Всего просмотров:
1304
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
9
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-3508
CVE-2014-5139
CVE-2014-3509
CVE-2014-3505
CVE-2014-3506
CVE-2014-3507
CVE-2014-3510
CVE-2014-3511
CVE-2014-3512
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenSSL 0.9.8
OpenSSL 1.0.0
OpenSSL 1.0.1
Уязвимые версии:
OpenSSL 0.9.8
OpenSSL 1.0.0
OpenSSL 1.0.1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к определенной конфиденциальной информации и вызвать отказ в обслуживании.

1. Уязвимость существует из-за ошибки в функциях "X509_name_oneline", "X509_name_print_ex" и т.п. Удаленный пользователь может получит доступ к потенциально важной информации.

2. Уязвимость существует из-за ошибки разыменования нулевого указателя. Удаленный пользователь может вызвать отказ в обслуживании.

3. Уязвимость существует из-за ошибки состояния операции в ssl_parse_serverhello_tlsext. Удаленный пользователь может записать до 255 байт произвольных данных на клиенте.

4. Уязвимость существует из-за ошибки двойного освобождения при обработке DTLS пакетов. Удаленный пользователь может вызвать отказ в обслуживании.

5. Уязвимость существует из-за ошибки при обработке DTLS пакетов. Удаленный пользователь может увеличить потребление памяти и вызвать отказ в обслуживании.

6. Уязвимость существует из-за ошибки при обработке DTLS пакетов. Удаленный пользователь может с помощью специально сформированного DTLS пакета получить доступ к потенциально важной информации.

7. Уязвимость существует из-за ошибки при обработке рукопожатий. Удаленный пользователь может вызвать отказ в обслуживании клиента.

8. Уязвимость существует из-за ошибки в серверном коде OpenSSL SSL/TLS. Удаленный пользователь может понизить версию используемого протокола и, соответственно, защищенность соединения.

9. Уязвимость существует из-за ошибки при обработке SRP параметров. Удаленный пользователь может спровоцировать переполнение буфера и вызвать отказ в обслуживании.

URL производителя: https://www.openssl.org/

Решение: Установите последнюю версию 0.9.8zb, 1.0.0n или 1.0.1i с сайта производителя.



Ссылки: https://www.openssl.org/news/secadv_20140806.txt