SQL-инъекция в PHPBTTracker+

Дата публикации:06.06.2014
Всего просмотров:749
Опасность:
Средняя
Наличие исправления: Нет
Количество уязвимостей:1
CVSSv2 рейтинг: 7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:U/RC:C)
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Неавторизованное изменение данных
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: PHPBTTracker+ 2.x
Уязвимые версии: PHPBTTracker+ 2.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре HTTP заголовка "User-Agent" в сценарии tracker.php (когда "event" установлен в положении "started", "info_hash", "peer_id", "port", "uploaded", "downloaded" и "left"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://phpbttrkplus.sourceforge.net/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.exploit-db.com/exploits/33626/