Компрометация системы в PHP

Дата публикации:17.04.2014
Всего просмотров:1080
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVSSv2 рейтинг: 7.1 (AV:N/AC:M/Au:N/C:N/I:C/A:N/E:U/RL:O/RC:C)
CVE ID: CVE-2013-4113
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: PHP 5.3.x
PHP 5.5.x
Уязвимые версии: PHP 5.3.x, PHP 5.5.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки в файле ext/xml/xml.c при обработке данных XML. Удаленный пользователь может вызвать переполнение буфера памяти.

URL производителя: http://www.php.net/

Решение: Установите последнюю версию 5.3.27 или 5.5.1с сайта производителя.

Ссылки: https://bugs.php.net/bug.php?id=65236
http://www.php.net/ChangeLog-5.php#5.3.27
http://php.net/archive/2013.php#id2013-07-18-1