Раскрытие информации в OpenSSL

Дата публикации:08.04.2014
Всего просмотров:4148
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVSSv2 рейтинг: 7.8 (AV:N/AC:L/Au:N/C:C/I:N/A:N/E:F/RL:O/RC:C)
CVE ID: CVE-2014-0160
Вектор эксплуатации: Удаленная
Воздействие: Раскрытие важных данных
CWE ID: Нет данных
Наличие эксплоита: Функциональный эксплоит
Уязвимые продукты: OpenSSL 1.x
Уязвимые версии: OpenSSL 1.0.1 через 1.0.1f, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к определенной конфиденциальной информации.

Уязвимость существует из-за ошибки проверки границ данных при обработке расширения TLS. Удаленный пользователь может раскрыть содержимое памяти подключенного клиента или сервера.

URL производителя: http://www.openssl.org/

Решение: Установите последнюю версию 1.0.1g с сайта производителя.

Эксплоит: CVE-2014-0160 OpenSSL 1.0.1 - Memory leak exploit

http://www.openssl.org/news/secadv_20140407.txt
Журнал изменений: a:2:{s:4:"TEXT";s:41:"08.04.2014 - добавлена ссылка на эксплоит";s:4:"TYPE";s:4:"html";}