Компрометация системы в Quagga

Дата публикации:02.04.2014
Всего просмотров:805
Опасность:
Средняя
Наличие исправления: Нет
Количество уязвимостей:1
CVSSv2 рейтинг: 8.3 (AV:A/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C)
CVE ID: CVE-2013-2236
Вектор эксплуатации: Локальная сеть
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Quagga 0.x
Уязвимые версии: Quagga 0.99.22, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в ospfd в функции "new_msg_lsa_change_notify()" в файле ospfd/ospf_api.c при обработке LSAs. Удаленный пользователь может вызвать переполнение стека буфера памяти.

Для успешной эксплуатации уязвимости пользователь может выполнить произвольный код.

URL производителя: http://www.nongnu.org/quagga/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://lists.quagga.net/pipermail/quagga-dev/2013-July/010622.html