Переполнение буфера в Xen

Дата публикации:25.03.2014
Всего просмотров:534
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVSSv2 рейтинг: 4.6 (AV:L/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C)
CVE ID: Нет данных
Вектор эксплуатации: Локальная
Воздействие: Отказ в обслуживании
Повышение привилегий
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: Xen 4.x
Уязвимые версии: Xen 4.2.x и 4.3.x, возможно более ранние версии

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе и вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки в libvchan при обработке xenstore индексов. Удаленный пользователь может с помощью специально сформированного xenstore содержимого вызвать переполнение буфера.

URL производителя: http://www.xenproject.org/developers/teams/hypervisor.html

Решение: Установите исправление xsa86.patch с сайта производителя.

Ссылки: http://xenbits.xenproject.org/xsa/advisory-86.html