Компрометация системы в OpenSSL

Дата публикации:20.04.2012
Всего просмотров:3258
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVSSv2 рейтинг: 10 (AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:O/RC:C)
CVE ID: CVE-2012-2110
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: OpenSSL 0.x
OpenSSL 1.x
Уязвимые версии:
OpenSSL 0.9.8v
OpenSSL 1.0.1a
OpenSSL 1.0.0i.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки в функциях при обработке данных в формате DER. Удаленный пользователь может с помощью специально сформированного файла, содержащего данные в формате DER, выполнить произвольный код на целевой системе.

Примечание: Уязвимость не распространяется на SSL/TLS код.

URL производителя: http://openssl.org

Решение: Для устранения уязвимости установите продукт версии 1.0.1a, 1.0.0i или 0.9.8v с сайта производителей.

Ссылки: http://www.openssl.org/news/secadv_20120419.txt
http://seclists.org/fulldisclosure/2012/Apr/210