Security Lab

Компрометация системы в VLC Media Player

Дата публикации:19.03.2012
Всего просмотров:2344
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:2
CVSSv2 рейтинг: 10 (AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:O/RC:C)
10 (AV:N/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:O/RC:C)
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: VLC Media Player 2.x
Уязвимые версии: VLC Media Player версии до 2.0.1

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных в функции "MMSOpen()" (modules/access/mms/mmstu.c) в плагине доступа MMS (libaccess_mms_plugin). Удаленный пользователь может с помощью специально сформированного MMS потока вызвать переполнение буфера в стеке и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за некоторых ошибок в плагине доступа realrtsp (libaccess_realrtsp_plugin) при обработке потоков Real rtsp. Удаленный пользователь может вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: http://www.videolan.org/vlc/

Решение: Установите последнюю версию 2.0.1 с сайта производителя.

Ссылки: http://www.videolan.org/security/sa1201.html
http://www.videolan.org/security/sa1202.html
Журнал изменений: a:2:{s:4:"TEXT";s:50:"19.03.2012
Изменено описание уязвимости #2.";s:4:"TYPE";s:4:"html";}