Security Lab

Множественные уязвимости в PostgreSQL

Дата публикации:28.02.2012
Дата изменения:01.03.2012
Всего просмотров:2402
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:3
CVSSv2 рейтинг: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P/E:ND/RL:O/RC:C)
6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P/E:ND/RL:O/RC:C)
6.4 (AV:N/AC:L/Au:N/C:P/I:P/A:N/E:ND/RL:O/RC:C)
CVE ID: CVE-2012-0866
CVE-2012-0867
CVE-2012-0868
Вектор эксплуатации: Удаленная
Воздействие: Неавторизованное изменение данных
Обход ограничений безопасности
Спуфинг атака
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: PostgreSQL 8.x
PostgreSQL 9.x
Уязвимые версии: PostgreSQL 9.1.3
PostgreSQL 8.3.18

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за ошибки при обработке параметров в CREATE TRIGGER, которая может привести к тому, что определенные параметры будут восприняты, как выражения SECURITY DEFINER.

2. Уязвимость существует из-за ошибки при проверке общего названия SSL сертификатов. Удаленный пользователь может успешно пройти проверку подлинности сертификата.

3. Уязвимость существует из-за недостаточной обработки входных данных в pg_dump при вставке имени объекта в комментарий. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://www.postgresql.org/

Решение: Установите исправление с сайта производителя.

Ссылки: http://www.postgresql.org/about/news/1377/
Журнал изменений: a:2:{s:4:"TEXT";s:42:"01.03.2012
Незначительные изменения";s:4:"TYPE";s:4:"html";}