Security Lab

Переполнение буфера при обработке сертификатов в yaSSL

Дата публикации:28.01.2010
Всего просмотров:1600
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Отказ в обслуживании
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: yaSSL Library 1.x
Уязвимые версии: yaSSL версии до 1.9.9

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки при обработке сертификатов. Удаленный пользователь может с помощью специально сформированного сертификата во время SSL рукопожатия вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.yassl.com

Решение: Установите последнюю версию 1.9.9 с сайта производителя.

Ссылки: http://www.yassl.com/news.html#yassl199
http://yassl.cvs.sourceforge.net/viewvc/yassl/yassl/taocrypt/src/asn.cpp?r1=1.13&r2=1.14
http://intevydis.blogspot.com/2010/01/mysq-yassl-stack-overflow.html