Инклюдинг локальных файлов в PostNuke PNphpBB2

Дата публикации:
12.01.2009
Дата изменения:
12.01.2009
Всего просмотров:
5536
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PNphpBB2 (модуль к PostNuke) 1.x
Уязвимые версии: PNphpBB2 (модуль к PostNuke) 1.2i, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным на системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "ModName" в сценариях "modules/PNphpBB2/admin/admin_words.php", "modules/PNphpBB2/admin/admin_groups_reapir.php", "modules/PNphpBB2/admin/admin_smilies.php", "modules/PNphpBB2/admin/admin_ranks.php", "modules/PNphpBB2/admin/admin_styles.php" и "modules/PNphpBB2/admin/admin_users.php". Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

URL производителя: www.pnphpbb.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: PNphpBB2 <= 1.2i (ModName) Multiple LFI Exploit