Межсайтовый скриптинг в HeXHub

Дата публикации:30.11.2008
Всего просмотров:1673
Опасность:
Низкая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Межсайтовый скриптинг
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: HeXHub 5.x
Уязвимые версии: HeXHub версии до HeXHub5.02cFirewall1.09

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в макросе "/report". Удаленный пользователь может с помощью специально сформированного запросы выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий в макросе "/report". Удаленный пользователь может произвести CSRF нападение.

URL производителя: sourceforge.net/projects/hexhub/

Решение: Установите последнюю версию HeXHub5.02cFirewall1.09 с сайта производителя.

Ссылки: http://sourceforge.net/project/shownotes.php?release_id=642276