Security Lab

PHP-инклюдинг в BrowserCRM

Дата публикации:09.06.2008
Всего просмотров:1381
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: CVE-2008-2689
CVE-2008-2690
Вектор эксплуатации: Удаленная
Воздействие: Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: BrowserCRM
Уязвимые версии: BrowserCRM 5.002.00, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "bcrm_pub_root" в сценариях pub/clients.php, pub/kb.php, pub/login.php, pub/index.php, pub/contact_view.php и pub/contact.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/pub/clients.php?bcrm_pub_root=[file]

URL производителя: www.browsercrm.com

Решение: Способов устранения уязвимости не существует в настоящее время.