Security Lab

PHP-инклюдинг в phpRaider

Дата публикации:26.05.2008
Дата изменения:18.08.2008
Всего просмотров:5467
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: CVE-2008-2481
CVE-2008-2769
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: phpRaider 1.x
Уязвимые версии: phpRaider 1.0.7a и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "pConfig_auth[phpbb_path]" в сценарии authentication/phpbb3/phpbb3.functions.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/authentication/phpbb3/phpbb3.functions.php?pConfig_auth[phpbb_path]=[file]

URL производителя: www.phpraider.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:


10.08.2008
Изменена секция "Решение".