Security Lab

PHP-инклюдинг в plusPHP Short URL Multi-User Script

Дата публикации:26.05.2008
Всего просмотров:2015
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: plusPHP Short URL Multi-User Script 1.x
Уязвимые версии: plusPHP Short URL Multi-User Script 1.6, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "_pages_dir" в сценарии plus.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/plus.php?_pages_dir=[file]

URL производителя: www.plusphp.com/Pages/52/plusPHP-Short-URL-Multi-User/

Решение: Способов устранения уязвимости не существует в настоящее время.