Security Lab

Переполнение буфера в XnView

Дата публикации:31.03.2008
Дата изменения:04.04.2008
Всего просмотров:1767
Опасность:
Высокая
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: XnView 1.x
Уязвимые версии: XnView 1.92.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке параметра "FontName" в *.sld файлах. Удаленный пользователь может с помощью специально сформированного файла, содержащего слишком длинный параметр "FontName", вызвать переполнении стека и выполнить произвольный код на целевой системе.

URL производителя: www.xnview.com

Решение: Установите последнюю версию 1.93.4 с сайта производителя.

Журнал изменений:

04.04.2008
Добавлен PoC код.

Ссылки: XnView 1.92.1 Slideshow (FontName) Buffer Overflow Exploit
Secunia Research: XnView Slideshow "FontName" Buffer Overflow Vulnerability