Security Lab

Переполнение буфера в jetAudio

Дата публикации:11.02.2008
Всего просмотров:1247
Опасность:
Высокая
Наличие исправления: Нет
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Удаленная
Воздействие: Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: jetAudio 7.x
Уязвимые версии: jetAudio 7.0.5, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке ASX файлов. Удаленный пользователь может с помощью слишком длинного URL в ASX файле вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.cowonamerica.com/download/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: jetAudio <= 7.0.5 (.ASX) Remote Stack Overflow Exploit PoC